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About This Document
This document provides information on the administrative tools which are available with Environment
Manager.

For each tool the guide describes how it should be used and includes a usage scenario to
demonstrate a circumstance in which the tool may be used.
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Environment Manager Administrative Tools
Environment Manager is packaged with the following standalone tools to assist administrators when
they create configurations and work with the Personalization database:

l Environment Manager Logging Setup
l Environment Manager Monitor
l Personalization Server Log Viewer
l Environment Manager Log File Conversion
l EMP File Utility
l EMPMigrate Utility
l EMPMigrate Command Line Utility
l EMP Registry Utility
l File Based Registry Explorer

The tools cover a range of functionality and employ a variety of user interfaces - from command line
utilities such as the EMP File utility to more extensive graphical interfaces such as the EM Log Viewer.

Installation
The 32 and 64-bit Administrative Tools installers are included with the Environment Manager
installation media:

l EnvironmentManagerTools32
l EnvironmentManagerTools64

Once installed to the default location, the tools are available from the Start > All Programs >
AppSense > AppSense > Toolsmenu.

The tools are run independently from Environment Manager and all our other products.
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Environment Manager Monitor
User Interface
Environment Manager Monitor (EmMon) provides a user interface to view and analyze log files from
the Environment Manager Agent. The tool replaces Environment Manager LogViewer.

The landing page displays when the Environment Manager Monitor loads. The landing page provides
access to load log files, view raw logs and analyze logs. Links are available to access commonly used
filters.

Label Description

a Load Log Files

Load a log file from disk. Recently used log files are populated in the drop-down menu.
Select the event types and logging level to load into Environment Manager Monitor.

For further details, see Loading Log Files.

b View Raw Logs from Live or Disk
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Label Description

View raw log lines from the live log or from a log file on disk. You can sort, filter, group,
search, and format the dataset.

For further details, see Viewing Raw Logs from Live or Disk.

c View Session Information

View detailed information about each user’s session from the loaded log file.

For further details, see Viewing Session Information.

d Analyze Log Files from Disk

View an analysis of a log file, either in a grid or chart. Log entries relating to the same
event are collected together.

The Analyze user activity option displays the analyzed view with no filters applied.

The dataset can be sorted, filtered, grouped, and searched. Built-in filters are available on
the landing page to provide access to the following commonly used tasks:

l Find personalization bottlenecks - Display long-running Personalization events.
l Find trigger bottlenecks - Display long-running Policy events.
l Search for any failures - Display Policy and Personalization failures.
l Search for failed actions and conditions - Display Policy failures.
l View failed personalization synchronizations - Display Personalization failures.
l View personalization server latency statistics - Display Personalization session
requests, configuration requests, application synchronizations and Windows
Personalization synchronizations.

l View windows/application personalization logging only - Display
Personalization session requests, configuration requests, application starts,
application synchronizations, Windows Personalization synchronizations, Windows
Personalization saves and Windows Personalization restores.

For further details, see Analyzing Log Files fromDisk.

e Viewing Loading Progress

When loading a log file, the loading progress displays. The log file may take a few minutes
to load depending on its size, event types and event detail.

After a log file is loaded, the number of log entries in the file displays.

f Selecting Loading Behavior

The Skip next time option can be set as follows:
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Label Description

l Disabled - The landing page displays when Environment Manager Monitor is
loaded.

l Enabled - The live log displays when Environment Manager Monitor is loaded. To
show the landing page for subsequent loads, click Options > Settings and enable
Show Landing Page.
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Load a Log File from Disk
1. From the Recent Log Files drop-down, select Open Log File.
2. From the Include Event Types drop-down, select the logging event types to load from the

selected log file. Options are available for specific user and computer events.
3. From the Include Detail Levels drop-down, select the logging level to load from the selected log

file and click OK. The following levels are available:
o Critical
o Error
o Warning
o Info
o Trace

4. Click .

A file browse dialog displays.

5. Select an ETL log file and click Open.

Environment Manager Monitor loads the log file. The loading progress displays at the bottom
of the dialog. The log file may take a few minutes to load depending on its size, event types and
event detail.

After opening a log file, the file is added to the Recent Log Files drop-down. To open a

recently used log file, select the file, event types, detail level and click

Clear the Recently Used Log Files List
1. From the Recent Log Files drop-down, select Clear Log Files.

2. Click .

3. Click Yes in the confirmation dialog.

Entries from the Recent Log Files drop-down are removed.

Copyright © 2019 , Ivanti. All Rights Reserved. Privacy and Legal.

Page 10 of 78

Environment Manager 2018.3 SP1 Administrative Tools Guide

https://www.ivanti.com/company/legal


View Raw Logs from Live or Disk
This view displays the raw log lines from either the live log or from a log file on disk.

You can sort, filter, group, search, and format the dataset to display the relevant information.

Log lines displayed in bold contain multiple lines that are not displayed in the view. To display the data,
either hover over the row or select Options > Auto Row Height.

Enable Logging
To enable logging on the endpoint, select Options > Settings > Logging Enabled. A reboot or agent
restart is not required. Logging can be enabled using the Environment Manager Logging Setup tool.

For further information, see Enable Logging. To view the live log in real time, see Load Live Logs.
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Change Logging Settings

Further logging settings are available within the Environment Manager Monitor. Use these settings to
define the name, location, detail level, components, and performance.

1. Select Options > Settings > Logging Settings.

The ETW Settings dialog displays.
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2. Set the required options for logging. The following settings are available:

Setting Description

Enable ETW logging Enable or disable logging on the local endpoint.

Log file name The location and name to which the log file is written.

Event tracing session
name

The name for the event tracing session. This name is used in
Performance Monitor.

Log detail The level of detail that is logged. The following options are
available:

l Critical
l Error
l Warning
l Informational
l Trace

Unless advised otherwise by Support, it is recommended
that the Log detail slider is set to Trace.

Components to enable The components that are logged. The following components are
available:

l EmCoreService
l EmUser
l EmSystem
l EmCredentialManager
l EmUserLogoff
l EmLoggedOnUser
l EmExit
l EmAuthenticationManager
l Winlogon notify package
l Winlogon detour
l EmWOW64
l EmLogoffUiApp

File size limit The maximum size of the log file in Mb if Circular Logging or Live
Logging is enabled.

Copyright © 2019 , Ivanti. All Rights Reserved. Privacy and Legal.

Page 13 of 78

Environment Manager 2018.3 SP1 Administrative Tools Guide

https://www.ivanti.com/company/legal


Setting Description

Max buffers The maximumnumber of buffers.

Buffer size The size of each buffer in Kb.

Min buffers The minimumnumber of buffers.

Log File Mode Set the log file mode. The following options are available:
l Rollover log - The log file grows to the specified size limit.
Once it has reached the limit, a new log file is created with a
version number appended to the name.

l Live log - Logging can be viewed in real time using the
Environment Manager Monitor. This is the equivalent of
Real Time logging in Windows Event Tracing.

l Circular log - The log file grows to the specified size limit.
Once it has reached the limit, the log file automatically
overwrites the oldest entries.

l Unlimited log - The log files grows indefinitely regardless
of the size limit.

3. Click OK.

The logging settings are applied. A reboot or agent restart is not required.

Loading Log Files

Load Live Logs

If logging is enabled in Live Log mode on the current endpoint, the live log file can be viewed in real
time. To view the live log, select File > Live Logs.

To stop the view automatically scrolling as new log entries are received, deselect Options > Auto
Scroll.

Load Log File From Disk

1. Select File >Open Log File.

A file browse dialog displays.

2. Select an ETL log file and click Open.

Environment Manager Monitor loads the log file. The loading progress displays at the bottom
of the dialog. The log file may take a few minutes to load depending on its size, event types and
event detail
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Load a Recently Used Log File

1. Select File > Recent Log Files.

A list of recently used log files displays.

2. Select a log file to open.

Environment Manager Monitor loads the log file. The loading progress displays at the bottom
of the dialog. The log file may take a few minutes to load depending on its size, event types and
event detail.

Export Log Files
1. Select File > Export.
2. Select a format to export to. The following options are available:

o Excel
o CSV
o Text
o Rich Text
o Web Page

o PDF

A file save dialog displays.

3. Select an export location and click Save.

The current dataset is exported to the selected location.

Manipulate the Data View

Add Columns

1. Right-click a column heading
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2. Select Column Chooser.

The Customization dialog displays.

3. Drag a column from the Customization dialog into the desired position on the header row.

Sort Columns

1. Right-click a column heading.
2. Select a sort order:

l Sort Ascending - Sort the data in ascending order.
l Sort Descending - Sort the data in descending order.

3. To clear the sorting, right-click the column heading and select Clear Sorting.

Filter Columns from Existing Values

This option displays all of the unique values for a field, such as all Session IDs, from the open log file.
Columns can be filtered by a specific value from the dataset.

1. Hover over a column heading and click the filter icon.

A list of unique values within the column displays.
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2. Select a value on which to filter the selected column.

The data is filtered to show only entries that match the criteria.

Filter Columns using Auto Filter Row

The Auto Filter Row displays above the dataset and allows columns to be filtered by entering basic
filtering criteria.

1. Select View > Filters > Auto Filter Row.

The Auto Filter Row displays below the column headings.
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2. To filter a column, enter the text into the Auto Filter Row.

The data is filtered to show only entries that match the criteria entered in the Auto Filter Row.

3. To clear the filtering, select View > Filters > Clear.

Filter Columns using Filter Editor

The Filter Editor allows conditions to be created to target specific data in the dataset. Complex
conditions can be created by using multiple expressions and nested Boolean operators.
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1. Select View > Filters > Filter Editor.

2. Edit the condition as required:

o Click a red Boolean operator, such as And, to edit the operator or add a new condition
group.

o Click a blue field name, such as [Time Stamp], to change the field to match.
o Click a green operator, such as Equals, to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click to add a new expression to the condition.

3. Click Apply to preview the filter.

4. Click OK.

The data is filtered to show only entries that match the criteria entered in the Filter Editor.

5. To clear the filtering, select View > Filters > Clear.

Group Columns

1. Select View > Groups > Group By Box.

The Group By box displays above the column headings.
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2. Drag a column heading into the Group By box. More columns can be dragged into the Group
By box to create nested groupings.

The data is grouped by the fields specified in the Group By box.

3. To clear the grouping, right-click the Group By box and select Clear Grouping.

Search Log Entries

1. Select Edit > Find Panel.The Find Panel displays above the column headings.

Enter a search term.

2. Click Find.Rows containing text in any column that matches the entered search term are
displayed.

3. To clear the search, click Clear in the Find Panel or close the Find Panel.

Add Conditional Formatting

Conditional formatting allows rows or text to be formatted based upon the data within one or more
fields.

1. Select Tools > View > Formatting Editor.

The Formatting Editor dialog displays.
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2. Click Add to add a new condition. Edit the condition as required:
o Click a red Boolean operator, such as And, to edit the operator or add a new condition
group.

o Click a blue field name, such as [Time Stamp], to change the field to match.
o Click a green operator, such as Equals, to edit the operator.
o Click either <enter a value> or a black value to enter a value.
o Click to add a new expression to the condition.

3. Once the condition has been constructed, set the formatting properties for rows that match
the condition. Available options include row background color, row border color and text
formatting.

4. Click Apply to preview the conditional formatting.
5. Click OK.
6. Rows matching the criteria specified in the Formatting Editor are formatted.
7. To clear the formatting, select View > Formatting > Clear.

View Footer

The footer allows statistics to be displayed for one or more fields. The sum, minimum, maximum, count,
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and average values are available for each field.

1. Select View > Footer.

The footer displays above the status bar.

2. Below a column, right-click the footer. Select a statistic from the following options:
o Sum
o Min
o Max
o Count

o Average

The statistic displays in the footer and automatically updates as data is added or removed.

Copy Log Lines to New Tab

One or more log lines can be copied to a new tab to allow the data to be analyzed independently. Tabs
can be renamed to make it easier to work with multiple tabs.

1. Select one or more log lines from the log file. Multiple lines can be selected by using the Ctrl or
Shift keys.

2. Select Edit > Copy To New Tab
3. A new tab is created containing the selected log lines.
4. To rename the created tab, right-click the tab and select Rename.

Merge and Compare Tabs

Data from two tabs can be merged and compared in a single view. The rows are color-coded to
differentiate between the two sources.

1. Select the first tab to compare.

2. Select Tools > Compare With.

A list of open tabs displays.
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3. Select a tab to compare with the current tab.

The Compare Tabs dialog displays.

Log lines that are present in both tabs display in white, those from only the first tab display in
red and those from only the second tab display in yellow.
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4. Click to access merge and compare options.

5. Change the options as required and click Refresh. The following options are available:
o Visible - Change the columns that are displayed in the comparison.

o Calculated - Change the columns that are used for the comparison.

The merged data is displayed with the specified columns visible.

Look Up Error Codes

Look up system error codes from the log file using the built-in tool.

1. Click Tools > Error Code Lookup.

The Error Code Lookup dialog displays.

2. Enter an error code.
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3. Click .

The error information displays for the entered error code.

View Session Information
The Session Information dialog provides information about each user session from the loaded log file.

The drop-down lists the session number and the logon and logoff times. When a session is selected,
detailed information about the session displays.
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Analyze Log Files from Disk
This view displays an analysis of the loaded log file. Log entries relating to the same event are collected
together.

Grid View
The Grid view provides an analysis of activity. Each row is an event, such as an action or condition.
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You can sort, filter, group, search, and format the dataset to display the relevant information.

Add Columns

1. Right-click a column heading

2. Select Column Chooser.

The Customization dialog displays.

3. Drag a column from the Customization dialog into the desired position on the header row.
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Sort Columns

1. Right-click a column heading.
2. Select a sort order:

o Sort Ascending - Sort the data in ascending order.
o Sort Descending - Sort the data in descending order.

3. To clear the sorting, right-click the column heading and select Clear Sorting.

Filter Columns from Existing Values

This option displays all of the unique values for a field, such as all Session IDs, from the open log file.
Columns can be filtered by a specific value from the dataset.

1. Hover over a column heading and click the filter icon.

A list of unique values within the column displays.

2. Select a value on which to filter the selected column.
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The data is filtered to show only entries that match the criteria.

3. To clear the filtering, right-click the column heading and select Clear Filter.

Filter Columns using Auto Filter Row

The Auto Filter Row displays above the dataset and allows columns to be filtered by entering basic
filtering criteria.

1. Right-click a column heading and select Show > Auto Filter Row.

The Auto Filter Row displays below the column headings.

2. To filter a column, enter text into the Auto Filter Row.

The data is filtered to show only entries that match the criteria entered in the Auto Filter Row.

3. To clear the filtering, right-click the column heading and select Clear Filter.

Filter Columns using Filter Editor

In the Filter Editor, create conditions to target specific data in the dataset. Use multiple expressions
and nested Boolean operators to create complex conditions.

1. Right-click a column heading and select Filter Editor.

The Filter Editor dialog displays.
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2. Edit the condition as required:
o Click a red Boolean operator, such as And, to edit the operator or add a new condition
group.

o Click a blue field name, such as [Time Stamp], to change the field to match.
o Click a green operator, such as Equals, to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click to add a new expression to the condition.

3. Click Apply to preview the filter.

4. Click OK.

The data is filtered to show only entries that match the criteria entered in the Filter Editor.

5. To clear the filtering, right-click a column heading and select Clear Filter.

Group Columns

Data can be grouped by one or more columns to create nested datasets. By default, the view is
grouped by Username followed by Session Description to create a nested view of users and each
user’s sessions.

The username and Session ID are captured at logon. If logging is enabled mid-session, these fields
may not be populated.
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1. Right-click a column and select Group By Box.

The Group By box displays above the column headings.

2. Drag a column heading into the Group By box. More columns can be dragged into the Group
By box to create nested groupings.

The data is grouped by the fields specified in the Group By box.

3. To clear the grouping, right-click on the Group By box and select Clear Grouping.

Export and Compress Session Logs

Individual session logs can be exported and compressed in ZIP format. The log can be emailed to
Support if required. Group the log by Username followed by Session Description. For further
information, see Group Columns.

1. Right-click a session heading and select Export and Compress Session.
2. The Browse for Folder dialog displays.
3. Select a location to save the exported session log and click OK.
4. The session log is exported to the selected location.

Search Log Entries

1. Click inside the grid.

2. Press Ctrl+F.

The Find Panel displays above the column headings.

3. Enter a search term.
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4. Click Find.

Rows containing text in any column that matches the entered search term are displayed.

5. To clear the search, click Clear in the Find Panel or close the Find Panel.

Recalculate Times

The start date and time of the log can be set to a different date and time. This allows timings of each
event to be displayed relative to a specified date and time.

Add the Start Time (calculated) and End Time (calculated) columns to the grid.

For further information about adding columns, see Add Columns.

1. Right-click in the work area and select Update Calculated Times.

The Recalculate Times dialog displays.

2. Enter a date and time for the start of the log. To specify the current date and time, click Now.

3. Click OK.

The Start Time (calculated) and End Time (calculated) columns update to represent the log start
time specified.
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Change Row Colors

Modify default row background colors to uniquely identify event types.

1. Right-click a row and select Update Colors.

2. The Update Colors dialog displays.

3. From the Event field, select the event type.
4. From the Event Color field, select a new color for the event. ClickMore Colors to set a custom

color.
5. Click OK.
6. To revert to the default colors, open the Update Colors dialog and click Reset.

Chart View
The Chart View provides a graphical representation of activity over time. Each bar is an event, such as
an action or condition.

The drop-down lists user sessions in the loaded log file. From the drop-down, filter the chart by
selecting or deselecting user sessions.

Use the mouse scroll wheel to change the zoom level or press Ctrl+Plus to zoom in and Ctrl+Minus to
zoomout. To zoom to a specific chart area, press Shift and draw a rectangle around the required
elements. If zoomed in, drag within the chart to pan.

The context menu provides view options, such as bar and axis labels.
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To display the bar relating to a specific event from the Grid view, right-click the row and select Show in
Chart. To display the row relating to a specific bar from the Chart view, right-click the bar and select
Show in Grid.

Filters Pane
The Filters pane provides filters that can be applied to the current dataset.

You can apply trigger filters in conjunction with other selected filters. For example, selecting Logon
and Actions displays action events in the Logon trigger.

To show events for the Citrix vDisk Client Settings condition, add File & Folder to the filter.
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To apply filters:

1. Click Filters to expand the Filters pane.
2. Select the required filters. Click Select All to select all filters or Deselect All to deselect all filters.

3. Click Refresh.

The filter is applied to the grid or list.

4. To clear the filtering, expand the Filters pane, click Select All and click Refresh.

Details Pane
The Details pane provides further information about the selected item in the Grid or Chart view.

The left-hand section shows detailed information about the event, such as error details, duration, user
name, user session, and Policy configuration node path. The right-hand section shows the raw log
lines for the selected event.
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You can sort, filter, group, and search the data in the Details pane just as you can in the work area.

For more information, see Work Area.

Look Up Error Codes
Look up system error codes from the log file using the built-in tool.

1. Right-click within the work area and select Error Code Lookup.

The Error Code Lookup dialog displays.

2. Enter an error code.

3. Click .

The error information displays for the entered error code.
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User Scenarios
The following sections provide procedures to guide you through common tasks when using this
feature. The scenarios are high level with the processes already documented elsewhere in Environment
Manager Administrative Tools. Theymay not exactly reflect your particular Environment Manager setup
or business requirements but demonstrate how the feature can be used.

Diagnose a Failed Map Drive Action

Scenario
As an administrator, you want to diagnose why a Map Drive action in your Policy configuration fails.

Process
In the Environment Manager Monitor tool:

1. Load an Environment Manager log file from an affected user.
2. Click Search for failed actions and conditions.
3. In the Filters pane, deselect all actions and conditions except for Map Drive and click Refresh.
4. In the work area, select one of the failures.

In the Details pane, the error code and error details display.

Result
The path to the mapped drive cannot be found. Check the Policy configuration to ensure that the
path is correct.

View Long-Running Logon Actions

Scenario
As an administrator, you want to locate long-running Logon actions in the Policy configuration.
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Process
In the Environment Manager Monitor tool:

1. Load an Environment Manager log file.
2. Click Find trigger bottlenecks.
3. In the Filters pane, deselect all triggers except for Logon and click Refresh.

4. Sort the work area by the Duration field in descending order.

The work area displays the longest running Logon actions.

In the following example, the Logon trigger took 5s 307ms to complete due to four failing Map
Drive and Map Printer actions:

Result
The failure of the Map Drive and Map Printer actions need to be investigated. If the Policy
configuration is incorrect, it requires updating to avoid this action failing or timing out on each user
logon.

For a user scenario about investigating failed Map Drive actions, see Diagnose a Failed Map Drive
Action.

View Bottlenecks for Single Session

Scenario
As an administrator, you want to locate Policy or Personalization bottlenecks within a single user
session.
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Process
1. In the Environment Manager Monitor tool:
2. Load an Environment Manager log file.
3. Click View/Search all detailed logging.
4. Filter the view so that only a single session is displayed.
5. Select Parsing > Find trigger bottlenecks to view Policy bottlenecks or Parsing > Find

personalization bottlenecks to view Personalization bottlenecks.

Result
The bottleneck report is displayed for a single user session only. The report can be analyzed to
compare multiple user sessions.
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Environment Manager Logging Setup
The Environment Manager Logging Setup tool provides a user interface to enable and disable the
generation of diagnostic log files.

Administrators or our Support teammay need log files to diagnose unexpected Environment
Manager behavior, such as Personalization failing for a specific application, or Policy configuration
actions not applying as expected.

Environment Manager uses Event Tracing for Windows (ETW) to record log events. Log files are stored
in ETL format that can be opened using Environment Manager Monitor.

For information about using Environment Manager Monitor to view and analyze ETL files, see
Environment Manager Monitor.

User Interface
Enable or disable logging in the user interface. Use the options to enable logging for specific
components or set advanced logging settings.
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Enable Logging
1. Click the On/Off button located at the top left-hand corner of the dialog to enable logging.

2. Select the General logging tab and modify the settings as required.

Setting Description

Enable ETW logging Enable or disable logging on the local endpoint.

Log file name The location and name to which the log file is written.

Event tracing session
name

The name for the event tracing session. This name is used in
Performance Monitor.

Log detail The level of detail that is logged.

Unless advised otherwise by Support, it is recommended
that the Log detail slider is set to Trace.

Components to enable The components that are logged.

File size limit The maximum size of the log file in Mb if Circular Logging or Live
Logging is enabled.

Max buffers The maximumnumber of buffers.

Buffer size The size of each buffer in Kb.

Min buffers The minimumnumber of buffers.

Log File Mode Set the log file mode. The following options are available:
l Rollover log - The log file grows to the specified size limit.
Once it has reached the limit, a new log file is created with a
version number appended to the name.

l Live log - Logging can be viewed in real time using the
Environment Manager Monitor. This is the equivalent of
Real Time logging in Windows Event Tracing. For more
information about opening the live log in the Environment
Manager Monitor, see Load Live Logs.

l Circular log - The log file grows to the specified size limit.
Once it has reached the limit, the log file automatically
overwrites the oldest entries.

l Unlimited log - The log files grows indefinitely regardless
of the size limit.
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3. Select theManaged Application logging tab and modify the settings as required.

Setting Description

Enable PVC
logging

Enable or disable logging for the PVC (Personalization Virtualization
Component). A separate log is generated for each managed process
that runs on the endpoint. PVC logging is in text file format.

Enable FBR
logging

Enable or disable logging for the FBR (File Based Registry) files used for
Application Personalization. FBR logging is in text file format

Enable FBR
logging if a file is
detected as
corrupted

Enable or disable logging for the FBR (File Based Registry) files used for
Application Personalization if an FBR file is detected as corrupted.

Check FBR file for
corruption when
logging enabled

Check FBR files for corruption and attempt to repair the file where
possible.

Logging must be enabled for this setting to take effect.

Enabling PVC or FBR logging causes a significant increase in system utilization. Unless
reproducing a problem or advised otherwise by our Support team, it is recommended that FBR
and PVC logging are disabled.
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4. Select the Locked down application logging tab and modify the settings as required.

Setting Description

Enable Lockdown
logging

Enable or disable logging for Environment Manager Policy
Lockdown activity. Lockdown logging is in text file format. Select
which applications are logged:

l All applications - Log Lockdown activity for all
applications.

l The selected application - Log Lockdown activity for
specific applications. Enter one or more executable names
in the Application name field. Separate executable names
with semicolons.

Enable EmLoader
logging

Enable or disable logging for the injection of the EmLoader
component. EmLoader logging is in text file format

EmLoader and
Lockdown log directory

The location and name to which the EmLoader and Lockdown log
files are written.

Enabling EmUser or Lockdown logging causes a significant increase in system utilization. Unless
reproducing a problem or advised otherwise by Support, it is recommended that EmUser and
Lockdown logging are disabled.

5. Click OK
6. A confirmatory dialog displays.
7. Click OK to confirm.

A log file is created in the specified location and logging is enabled on the endpoint. A reboot or
agent restart is not required for the change to take effect.

Disable Logging
1. Click the On/Off button located at the top left-hand corner of the dialog to disable logging.

2. Click OK.

A confirmatory dialog displays.

3. Click OK to confirm.

Logging is disabled on the endpoint. A reboot or agent restart is not required for the change
to take effect.
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Personalization Server Log Viewer
Interface Overview
Personalization Server Log Viewer provides a user interface to view and analyze log files from the
Environment Manager Personalization Server.

The tool is compatible with Personalization Server log files in an ETL format only

For information on how to analyze endpoint log files, see Environment Manager Monitor.

Load a Log File
1. Select File >Open.

A file browse dialog displays.

2. Select an ETL log file and click Open.

Personalization Server Log Viewer loads the log file. The loading progress displays at the
bottom of the dialog.
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Export Logs
1. Select File > Export.

Select a format to export to. The following options are available:

o Excel
o CSV
o Text
o Rich Text
o Web Page

o PDF:

A file save dialog displays

2. .Select an export location and click Save.

The current dataset is exported to the selected location.

Sort Columns
Right-click a column heading.

Select a sort order:

l Sort Ascending - Sort the data in ascending order.
l Sort Descending - Sort the data in descending order.

To clear the sorting, right-click the column heading and select Clear Sorting.

Filter Columns from Existing Values
This option displays all of the unique values for a field, such as all Thread IDs, from the open log file.
Columns can be filtered by a specific value from the dataset.

1. Hover over a column heading and click the filter icon.

A list of unique values within the column displays.
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2. Select a value on which to filter the selected column.

The data is filtered to show only entries that match the criteria.

To clear the filtering, right-click the column heading and select Clear Filter.

Filter Columns using Auto Filter Row
The Auto Filter Row displays above the dataset and allows columns to be filtered by entering basic
filtering criteria.

1. Right-click a column heading and select Show Auto Filter Row.:
2. The Auto Filter Row displays below the column headings.

3. To filter a column, enter text into the Auto Filter Row.

The data is filtered to show only entries that match the criteria entered in the Auto Filter Row.

4. To clear the filtering, right-click the column heading and select Clear Filter.
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Filter Columns using Filter Editor
The Filter Editor allows conditions to be created to target specific data in the dataset. Use multiple
expressions and nested Boolean operators to crate complex conditions.

1. Right-click a column heading and select Filter Editor.

The Filter Editor dialog displays.

2. Edit the condition as required:
o Click a red Boolean operator, such as And to edit the operator or add a new condition
group.

o Click a blue field name such as [Time Stamp] to change the field to match.
o Click a green operator such as Equals to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click to add a new expression to the condition.

3. Click Apply to preview the filter.

4. Click OK.

The data is filtered to show only entries that match the criteria entered in the Filter Editor.

To clear the filtering, right-click a column heading and select Clear Filter.

Group Columns
Data can be grouped by one or more columns to create nested datasets.
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1. Right-click a column and select Group By Box.

The Group By box displays above the column headings.

2. Drag a column heading into the Group By box. More columns can be dragged into the Group
By box to create nested groupings.

The data is grouped by the fields specified in the Group By box.

To clear the grouping, right-click on the Group By box and select Clear Grouping.

Search Log Entries
1. Press Ctrl+F.

The Find Panel displays above the column headings.

2. Enter a search term.

3. Click Find.

Rows containing text in any column that matches the entered search term are displayed.

To clear the search, click Clear in the Find Panel or close the Find Panel.

Command Line Interface
The Personalization Server Log Viewer tool also provides a command line interface. The following
commands are available:

l Open the user interface

EtwLogFileReader.exe

l Open an ETL log file in the user interface

EtwLogFileReader.exe C:\Logs\Input.etl
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l Convert an ETL log file to text file

EtwLogFileReader.exe C:\Logs\Input.etl /export

l Convert an ETL log file to text file in a different output directory

EtwLogFileReader.exe C:\Logs\Input.etl /export:C:\Temp\Output.txt
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Environment Manager Log File Conversion
The Environment Manager Log File Conversion tool (Etl2Txt) is a command line driven tool to convert
ETL log files to text files.

It is recommended that the Environment Manager Monitor is used to view and analyze ETL
log files. For further information, see Environment Manager Monitor.

The Environment Manager Log File Conversion tool is located in the Tools installation folder and is run
from the command prompt.

To run the Environment Manager Log File Conversion tool:

1. Open the Run dialog and enter cmd.exe.
2. Using the command prompt, navigate the Tools installation folder -

%ProgramFiles%\AppSense\Environment Manager\Tools\.
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3. Run the Etl2Txt.exe, together with the appropriate parameters as detailed in the following
table:

Parameters Input
Arguments

Parameter Details

-?

-help

n/a Outputs the help text to the console.

-f

--filename

filename Specify the name of the source ETL file to convert.

This is a required parameter.

-c

--components

components Specify the name of the Environment Manager
components to include in the conversion:

l EmUser
l EmCoreService
l EmSystem
l EmUserLogoff
l Other

Separate multiple components with a space.

If the parameter is not specified, all components are
included by default.

-s

--split_output

yes or no Specify whether output log files are split or collated:
l yes - Output log files split by Environment
Manager component.

l no - Output a single collated log file for all
Environment Manager components.

If the parameter is not specified, the argument
defaults to yes.

-i

--include_events

yes or no Specify whether trace events are included in the
output:

l yes - Output trace events with the raw log
lines.

l no - Output raw log lines only.

If the parameter is not specified, the argument
defaults to no.
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Parameters Input
Arguments

Parameter Details

-e

--events_only

yes or no Specify whether trace events are output:
l yes - Output trace events only.
l no - Output raw log lines and, if --include_

events is set to yes, trace events.

If the parameter is not specified, the argument
defaults to no.

-o

--output_dir

path Specify the directory for the output files.

If the parameter is not specified, the current
directory is used for the output.

-t

--text_levels

yes or no Specify how log levels are displayed:
l yes - Output log levels as text.
l no - Output log levels as numbers.

If the parameter is not specified, the argument
defaults to no.
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EMP File Utility
The Environment Manager Personalization File Utility (EMP File Utility) imports and exports files to and
from the Environment Manager Personalization database using a command-line interface. Before the
tool can be used, a valid connection string to the database must be defined. The user specified in the
connection string must have the privilege to read, write, and run stored procedures in the database.
The simplest privilege is "dbowner".

The utility accesses the database directly and does not use a Personalization Server.

This is a low level tool that uses elements of scripting in the command-line interface to input
commands and set parameters. A knowledge of command-line utilities and scripting is an
advantage when using this tool.

Requirements
A username and password of a user with access to the database tables is required because the utility
accesses the database directly. Using the Personalization service account will not work.

Supported software versions
The EMP file utility no longer supports older versions of Environment Manager. The 8.5 utility can only
be used on software version 8.5.
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Windows Settings Group Support
The file utility may be used to import and export files fromwindows settings groups contained in the
parent Windows Settings profile. To do this the application name is replaced by the Windows setting
group name prefixed by "wsg:". For example, to import and export from the Windows Setting group
named Appearance and Personalization, specifywsg:Appearance and Personalization as the application
name.

Usage Scenario
A typical scenario is when a specific user or group requires that a certain file is updated through a
batch process rather than via a user interface. The EMP File Utility can also be used in conjunction with
Environment Manager Policy Configuration to directly manipulate the users settings within the
database.

Export a File from a Database
A valid connection string to the database must be defined in the environment variable
EMPFileUtilConnectionString in the same command window in which EMPFileUtil is run. This
procedure shows how to set the environment variable and then run the utility.

1. Select Start > AppSense > Environment Manager> Tools > EMP File Utility.

2. On the command line, enter SET EMPFileUtilConnectionString=<connection
string>

For example, SET EMPFileUtilConnectionString=Data Source=(local);Initial
Catalog=PersonalizationServer;Integrated Security=SSPI

3. Press Enter.

This environment variable can also be set globally in the System Properties. For
Windows Vista and above, right-click Computer on the Start menu and select
Properties. Select Advanced system settings, click the Advanced tab and select the
Environment Variables button.
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4. In the command line, enter a command in the following format: EMPFileUtil EXPORT
<username> <usergroup> <application> <databaseroot> <outputfolder>

Where:

Parameters Definition

<username> The user’s name with preceding domain, for example,
appsense\smithj

<usergroup> The personalization group for the user, for example, “Default
Users”

<application> The name of the application or group (not the name of the
executable, although it may be the same, for example Notepad), or
the name of the Windows Settings group prefixed by “wsg:”.

If the name contains spaces, the entire parameter, including the
wsg:, must be included in quotation marks The following reserved
application names are recognized:

l Certificates (for Legacy Certificates profile)
l Legacy Certificates
l Windows Settings
l Windows Personalization (for Windows Settings profile)
l Legacy Session Data

<databaseroot> The root of the file tree to be exported in “raw” format, for
example, {CSIDL_APPDATA}.

The value * (asterisk) may be used here to export all of the files in
the directory. This also exports the registry file “settings.fbr” (or
“registry.fbr” in the case of a Windows Setting group). These files
should be re-imported only to the same user because they contain
the user’s SID.

Note; In such cases it might be more appropriate to use the EMP
Registry Utility for transfer of registry settings.

See EMP Registry Utility for further details.

<outputfolder> The folder where the files are to be exported. A directory structure
is built here matching the one in the database. Relative paths can
be used, for example, a dot refers to the current path.
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Parameters Definition

Existing files are not overwritten and folders are created as
required.

Parameters Definition

<username> The user’s name with preceding domain, for example,
appsense\smithj

<usergroup> The personalization group for the user, for example, “Default
Users”

<application> The name of the application or group (not the name of the
executable, although it may be the same, for example Notepad), or
the name of the Windows Settings group prefixed by “wsg:”.

If the name contains spaces, the entire parameter, including the
wsg:, must be included in quotation marks The following reserved
application names are recognized:

l Certificates (for Legacy Certificates profile)
l Legacy Certificates
l Windows Settings
l Windows Personalization (for Windows Settings profile)
l Legacy Session Data

<databaseroot> The root of the file tree to be exported in “raw” format, for
example, {CSIDL_APPDATA}.

The value * (asterisk) may be used here to export all of the files in
the directory. This also exports the registry file “settings.fbr” (or
“registry.fbr” in the case of a Windows Setting group). These files
should be re-imported only to the same user because they contain
the user’s SID.

Note; In such cases it might be more appropriate to use the EMP
Registry Utility for transfer of registry settings.

See EMP Registry Utility for further details.

<outputfolder> The folder where the files are to be exported. A directory structure
is built here matching the one in the database. Relative paths can
be used, for example, a dot refers to the current path.
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Parameters Definition

Existing files are not overwritten and folders are created as
required.

Parameters must be enclosed in quotes if they include embedded spaces.

5. Press Enter to export all applicable files.

Import a File to the Database
Select Start > AppSense > Environment Manager> Tools > EMP File Utility.

On the command line enter a command in the following format:

EMPFileUtil IMPORT <importdescription>.xml

The XML file contains information about users, application groups, and files to be loaded into the
database.

There can be one XML file per user, or lots of users in the same file.

Example XML File

<?xml version="1.0" encoding="utf-8"?>

<Users>

<User

Name="appsense\smithj"

RetrieveSID="yes" >

<PersonalizationGroup

Name="Default Users">

<Application

Name="Group1"

Type="group"

DeleteExisting="yes"

RootFolder="c:\Dev\TestData\Group1" />

<Application

Name="Notepad"

Type="single"
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DeleteExisting="yes"

RootFolder="c:\TestImport\Notepad" />

</PersonalizationGroup>

</User>

<User

Name="appsense\jonesa"

RetrieveSID="no"

Sid="S-1-5-21-203209604-3446334822-3473717970-1002" >

<PersonalizationGroup

Name="Default Users">

<Application

Name="Office"

Type="group"

DeleteExisting="yes"

RootFolder="c:\TestImport\Office" />

<Application

Name="Notepad"

Type="single"

DeleteExisting="yes"

RootFolder="c:\TestImport\Notepad" />

</PersonalizationGroup>

</User>

</Users>

There can be one or more <User> elements under the top-leve l<Users> element. Each User element
can specify multiple Personalization groups (User groups) for a user if required.

Multiple applications can be specified under the <PersonalizationGroup>. Each application has a
folder where the utility finds the files to read - the RootFolder attribute.

Element Attribute Meaning

User Name User name in the form domain\user. This user need not
exist if the SID is specified. The user need not have
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Element Attribute Meaning

logged on to the Personalization server previously.

RetrieveSID Value is “yes” or “no”. If “yes”, EMPFileUtil will check AD
(if in a domain) or the local machine (if not) to find the
user's SID.

SID User's Sid, required if RetrieveSID=”no” has been
specified.

PersonalizationGroup Name Name of the group to which the user and applications
are to be loaded. This group must exist already. Note
that you will create redundant data if the memberships
do not put the user in the group.

Application Name Name of the application, application group or Windows
Settings group preceded by “wsg:”. A group must be
assigned to the Personalization Group or EMPFileUtil
reports an error. Reserved application names (as listed
for export above) may be used, but note that importing
into a legacy profile will only affect legacy clients.

Type “Single” for an application or “group” for an application
group.

DeleteExisting “Yes” or “no”. If the application already exists with data
for the user/group, specifying “yes” will cause
EMPFileUtil to delete all the old data. If “no”, new files
will be added. If a new file has the same name and path
as the old, a duplicate key error is generated and
processing stops.

Path where files to be imported are situated. The root
must contain subdirectories of the form {CSIDL_xxx},
and no files. Below this anything is allowed and will be
loaded into the database. Registry files cannot be
loaded - this must be done instead with EMPRegUtil.

Personalization Analysis
Once the XML file has been imported you can drill into the users settings using the Personalization
Analysis too.

For more information on Personalization Analysis see Personalization Analysis in the Environment
Manger Help system.
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EMP Migrate Utility
The Environment Manager Personalization Migrate Utility (EMPMigrate Utility) is a standalone tool
that allows user data to be copied from a source database to a target database, mapping the user
names to the target domain and adjusting saved registry settings accordingly. The utility contacts the
respective databases directly and does not use existing personalization servers.

The utility checks the personalization group of each user that it encounters on the source database
with a group of the same name on the target database. If incomparable data exists whereby users or
groups are listed on the source but not the target databases, an Import/Export operation from the
Environment Manager console has to be performed to align both the source and target databases.
When the comparison is complete you can view an output summary by clicking View Log.

The following table shows the EMPMigrate Utility version requirements for source and target
databases.

EMPMigrate Utility Version Source Version Target Version

8 FR4 8.1, 8.2, 8.3 or 8
FR4

8 FR4

8.5 8.5 8.5

8.6 8.5 or 8.6 8.6

10.x 8.5 or later 10.x

For more information about the Import/Export function, see Import and Export Personalization
Configurations in the Environment Manager help.

Usage counts are not transferred for applications so the count starts again on the new database.
Therefore transferred applications do not appear on the Application Usage report. Usage counts for
discovered applications are set to one on transfer and appear on the Discovered Application report.

Usage Scenario
Typical usage of the EMPMigrate Utility can be when a specific user or group requires access to, for
example, a User Acceptance Testing (UAT) environment for testing a particular application. The EMP
Migrate Utility can be used to migrate the users existing personalization data from a UAT database
into the production database to ensure the user has a consistent experience in both environments.

Another example is when a specific user is moving from one region to another, the EMPMigrate Utility
can be used to migrate the users personalization data ahead of time to ensure that the user has a
consistent experience in the new location.
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Runthe EMP Migrate Utility
1. Select Start > All Programs > AppSense > Environment Manager> Tools > EMP Migrate

Utility.
2. In the Target Database dialog, enter the following information for the target database that will

receive data:
o SQL Server Name\Instance
o SQL Database Name

o User ID and Password (or select Use Windows Authentication to use the current
Windows identity)

The user must have sufficient privileges to modify data in the tables directly in the
database. The service account user (used by Personalization Servers) is not sufficient, as
this only has permission to run stored procedures.
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3. Click OK to connect and display the console.

4. Click the ellipsis (...) to select the Source database.
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5. Select the domain mapping from the Domain mapping drop-down menu:
o Use current domain- The domain in which the utility is running is used
o Map to new domain- Use the ellipses to select the domain or enter the NetBIOS name
of the domain directly into the field.

o No domain mapping- Users are not modified if this option is selected. This is useful for
combining databases in the same domain.

If domain mapping is used, the domain of all selected users is altered to the target
database, regardless of the previous values. The utility must be able to look up the SID of
each user in the target domain.

The utility does not add the users to Active Directory for the target domain.

6. Select the users you want to add using the following options:
o Add Users - Select users from available groups. Enter the name, optional domain or
select a user group and click Search to display the users within that group.

o Click the Load file... button to load a list of users from a CSV file. Each user must be
separated by a comma:

o Add Groups - Select all users from a group.
o Add All Users - Select all available users from the database.

7. Users and groups can be taken out of the migration using the Remove button.
8. Once all the required users have been added, click OK.
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9. Click the Start Migration button to display the Migration Options.

10. Use the check boxes to apply the following settings:
o Ignore global data differences - If any global data differences exist between the source
and target databases the tool will ignore these discrepancies and proceed with the
migration. Global data refers to the global path data, such as global registry file path
includes and excludes and Windows Setting Groups.

o Replace existing users' data - If the same user is found for a user, the old data is
deleted and replaced by the source data. If unchecked the old data is not replaced.

o Copy archives - Archive data as well as current data is transferred.
o Copy discovered applications - Discovered applications are transferred.

11. Click Next to start the transfer.

12. A processing dialog displays, showing the number of transfers which pass and fail.

13. When complete, the Error and View Logs can be scrutinized using the available buttons. The
logs are written to the current user's Documents folder.

Copyright © 2019 , Ivanti. All Rights Reserved. Privacy and Legal.

Page 65 of 78

Environment Manager 2018.3 SP1 Administrative Tools Guide

https://www.ivanti.com/company/legal


14. Once you have migrated the data, you can launch the Personalization Analysis tool on the
target database to see the data exist for the migrated user.

The EMPMigrate Utility does not remove the users data from the source database.
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EMP Migrate Command Line Utility
The Environment Manager Personalization Migrate Command Line Utility (EMPMigrate Command Line
Utility) is a command line driven tool that allows user data to be copied from a source database to a
target database, mapping user names to the target domain and adjusting saved registry settings
accordingly. The utility contacts the respective databases directly and does not use existing
personalization servers. The EMPMigrate Command Line Utility provides the same functionality as the
EMPMigrate Utility.

The EMPMigrate Command Line Utility is located in the Tools installation folder and is run from the
command prompt.

Run the EMP Migrate Command Line Utility
1. Open the Run dialog and enter cmd.exe.
2. Using the command prompt, navigate the Tools installation folder:

%ProgramFiles%\AppSense\Environment Manager\Tools\
3. Run the EMPMigrateCmd.exe together with the appropriate parameters as detailed in the

table below.

EMPMigrate Command Line Utility Parameters

Parameters Input Arguments Parameter Details

/?

/help

n/a Outputs the help text to the console.

/sourcedb dbname The name of the source database.

This is a required parameter

/sourceinstance server[\\instance] The server or instance name for the source
database. The instance name is optional.

This is a required parameter.

/targetdb dbname The name of the target database.

/targetinstance server[\\instance] The server or instance for the target database.
The instance name is optional.

This is a required parameter.

/sourcewindowsauth true or false The authentication type used to connect to
the source database:
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Parameters Input Arguments Parameter Details

l true - use this argument to use the
Windows authentication type.

l false - use this argument to select the
SQL authentication type.

If an argument is not specified Windows
authentication is automatically used.

/sourcesqlusername username The username for SQL authentication on the
source database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/sourcesqlpassword password The password for SQL authentication on the
source database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/targetwindowsauth true or false The authentication type used to connect to
the target database:

l true - use this argument to use the
Windows authentication type.

l false - use this argument to select the
SQL authentication type.

If an argument is not specified Windows
authentication is automatically used

/targetsqlusername username The username for SQL authentication on the
target database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/targetsqlpassword password The password for SQL authentication on the
target database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/domainmapping [current]|[map]|
[nomap]

The type of mapping to apply for users to the
new domain. If not specified this parameter
defaults to current.

/mapto domainname The target domain name if the mapto
parameter is set tomap.
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Parameters Input Arguments Parameter Details

/users [all]|[group]|[list] Specifies which users to migrate:
l all - migrate all users.
l group - migrate users in a
personalization group.

l list - migrate user listed to a specified
file.

This is a required parameter.

If duplicate users are found in the source
database, only the most recent user will be
migrated.

/usersgroup groupname The name of the personalization group to
migrate. Used when users is set to group.

/userlist listfile Full path to a file containing a list of users to
migrate. Used then users is set to list.

The file path must be enclosed in quotation
marks. Each user listed in the file must be on a
separate line or in CSV format.

If a filename is specified without a path, the
EMPMigrateCmd.exe working directory is
assumed.

/options [replace],
[ignoreglobal],
[copyarchives],
[copydiscovered]

One or more of these options can be specified
by comma separating parameters:

l replace - this option replaces existing
user data in the target database.

l ignoreglobal - ignores differences in
global data settings.

l copyarchives - copies the user's
archives together with their current
data.

l copydiscovered - copies the user's
discovered applications.

/output outputfile The output location of the report file. When
specifying the output path, the path name
must be enclosed in quotation marks. If a path
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Parameters Input Arguments Parameter Details

has not been specified, a default path of
%USERPROFILE%\\Documents\\EMPMigrate.log
is used.

/threads number The number of threads used when migrating
the data. A value of 0 forces the number of
threads used to equal the processor count
and is the default value.

Required Format of User Names
User names must match the dbo.User.Name field in the Source database. These are in the down-level
logon name format as defined byMicrosoft. For example, the format for the user, ExampleUser, in the
local domain AppSense.local is APPSENSE\ExampleUser. Using the fully qualified APPSENSE.local
domain name causes the user to be ignored and not migrated. While technically correct, it does not
correspond to the Name field specified in the database.

The User Principal Name (UPN) format is not supported.

Usage Scenarios and Solutions
The following scenarios demonstrate how the EMPMigrate Command Line Utility can be used. For the
purpose of these scenarios SrcSql represents the source location and TgtSQL the target destination.
Each scenario includes an outline of a task to be completed, followed by the command line solution.

Scenario One
Using Windows Authentication, you are required to migrate a Personalization Group called Prod Users
to a new target location and replace existing user's data in the target database with from the source
database. To migrate the group, you must check if the Personalization Group exists on your target
location and check for no difference in the global data settings.

Solution
EMPMigrateCmd.exe /SourceInstance SrcSQL /SourceDB PSDB /TargetInstance
TgtSQL /TargetDB PSDB /Users Group /UserGroup "Prod Users" /Options Replace

Scenario Two
Using Explicit SQL Credentials for both the Source and Target locations, you are required to migrate all
users to a target location. The migration must replace existing Personalization Groups, ignoring any
global data differences but must not map to a new domain.
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Solution
EMPMigrate.exe /SourceInstance SrcSQL /SourceDB PSDB /SourceSQLusername sa
/SourceSQLPassword sourcePass /TargetInstance TgtSQL /TargetDB PSDB
/TargetSQLUsername sa TargetSQLPassword targetPass /DomainMapping NoMap
/Users All /Options Replace,IgnoreGlobal

Scenario Three
Using Windows Authentication in the source location, you are required to migrate a list of users found
in c:\Temp\UserList.txt to a target location that requires explicit SQL credentials. The migration must
replace existing Personalization Groups and include data for Discovered Applications. It must ignore
any difference in global data settings but must not map to a new domain.

Solution
EMPMigrate.exe /SourceInstance SrcSQL /SourceDB PSDB /TargetInstance TgtSQL
/TargetDB PSDB /TargetSQLUsername sa /TargetSQLPassword targetPass /Users
List /UserList "c:\Temp\UserList.txt" /Options
Replace,IgnoreGlobal,CopyDiscovered
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EMP Registry Utility
The Environment Manager Personalization Utility (EMP Registry Utility) is a command-line utility that
can import and export REG files to and from an Environment Manager personalization database. It
also includes a function to delete keys. The REG files are in the same format used by the Microsoft
RegEdit utility. All functions apply to a single application for a single user.

Requirements
A username and password of a user with access to the database tables is required because the utility
accesses the database directly. Using the Personalization service account will not work.

Windows Settings Group Support
The registry utility can be used to import and export registry setting files fromWindows Settings
groups contained in the parent “Windows Settings” profile. To do this the application name is
replaced by the Windows Setting group name prefixed by “wsg:”. So to import and export from the
Windows Setting group named “Appearance and Personalization”, specify “wsg:Appearance and
Personalization” as the application name.

Usage Scenario
A typical scenario is when a user or group requires that a certain registry key is updated through a
batch process rather than via a user interface. The EMP Registry Utility can also be used in conjunction
with Environment Manager Policy Configuration to directly manipulate the users settings within the
database.

Define a Connection String for the Database
A valid connection string to the database must be defined in the environment variable
EMPFileUtilConnectionString in the same command window that EMPRegUtil is run. This
procedure shows how to set the environment variable and subsequently run the utility.

1. Select Start > AppSense > Environment Manager> Tools > EMP Registry Utility .

2. On the command line, enter SET EMPRegUtilConnectionString=<connection
string>.

For example, SET EMPRegUtilConnectionString=Data Source=(local);Initial
Catalog=PersonalizationServer;Integrated Security=SSPI

3. Press Enter.
4. This environment variable can also be set globally in the System Properties.
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5. On the command line, enter EMPRegUtil followed by the command and parameters for the
required function:

o EXPORT <user> <group> <app> <key> <file>

o IMPORT <user> <group> <app> <file>

o DELETE <user> <group> <app> <key>

6. For example: EMPRegUtil EXPORT domain1\smithj “Default Users” Outlook
HKEY_CURRENT_USER\Software\Outlook Outlook.reg.

7. Press Enter to perform the specified function.
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File Based Registry Explorer
When Environment Manager personalizes an application on an endpoint, registry writes from the
application are captured to a File Based Registry (FBR) file called settings.fbr in the virtual cache for
that application. Registry keys captured are those defined in the global inclusion/exclusion list and any
application-specific list defined in the personalization database.

When the application exits, Environment Manager saves the cache contents, including the settings.fbr
file, to the personalization database. When the application is next run, the cache contents are
restored from the database.

The FBR Explorer provides a way to view the settings.fbr file on the endpoint. Although it is possible to
make edits to the file in the FBR Explorer, they are ineffective because the file will be overwritten with
the copy from the database the next time the application is run. To make changes, it is necessary to
edit the database copy using the registry edit function of Personalization Analysis in the Environment
Manager console.

Although the FBR Explorer is available to use it is recommended to use Personalization Analysis in the
Environment Manager console.

For more information, see the Ivanti Environment Manager Personalization Help.

Incorrectly editing the registry may severely damage your system. Before making changes to the
registry, you should back up any valued data on your computer.

Usage Scenario
The FBR Explorer is used to open the virtual FBR files created by User Personalization and allows you
to view a given users virtual registry for a given application. The FBR Explorer provides a client side
ability to open and view a FBR file for an application, allowing you to review which registry keys are
being used by the application with regards to the user.
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Create a New Entry or Data Type, Rename, or Delete
1. Select Start > All Programs > AppSense > Environment Manager> Tools > FBR Explorer.

2. Select File >Open.

The Open dialog displays.

3. Navigate to the FBR file and click Open.

The FBR file displays in the FBR Explorer and is organized into a tree format.

4. To refresh the FBR Explorer tree at any time, select File >Refresh or press the F5 key.
5. Perform one or more of the following actions:

o To create a new entry or data type, right-click a node or data type in the FBR Explorer
tree and select New.

o A new node or data type is created.
o To rename an entry or data type, right-click a node or data type and select Rename.
Enter the new name for the node or data type in the FBR Explorer tree.

o For a data type specify the Value type and Value data and click OK.

For more information on data types, see Data Types.
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6. To delete an entry, right-click the node and select Delete.

The node and all sub-nodes are deleted.:

When you delete a node or data type fromwithin the FBR Explorer it is automatically
deleted. A confirmation message is not displayed and you cannot undo. Ensure that
you want to delete the node before selecting the Delete command.

Export a FBR File from the FBR Explorer
You can export the entire FBR file for a single user or a section of the FBR file. The default export file
extension is REG. You can double-click this file to add the information contained within the file to the
registry.

1. Do one of the following:
o To export the complete FBR file for a user, right-click the Registry node in the FBR
Explorer tree and select Export.

o Right-click the node that contains the section you want to export and select Export.
2. Enter a name for the export file and click Save.

Edit the Data Value for a Data Type within an FBR File
1. Right-click the node that contains the data type and select Edit.

The Edit Value dialog displays.
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2. Edit the data value and click OK.

Data Types
The following table shows the data types currently defined and used by the system.

Data type Description

REG_BINARY Raw binary data. Most hardware component information is
stored as binary data and displays in the Registry Editor in
hexadecimal format.

REG_DWORD Data represented by a number that is 4 bytes long. Many
parameters for device drivers and services are this type and are
displayed in the Registry Editor in binary, hexadecimal, or decimal
format.

REG_EXPAND_SZ A variable length data string. This data type includes variables
that are resolved when a program or service uses the data.

REG_MULTI_SZ A multiple string. Values that contain lists or multiple values in a
form that people can read are usually this type. Entries are
separated by spaces, commas, or other marks.
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Data type Description

REG-SZ A fixed length text string.

REG_FULL_RESOURCE_
DESCRIPTOR

A series of nested arrays designed to store a resource list for a
hardware component or driver.
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